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Introduction

Terminology

This reference guide provides instructions on using Excel to analyze data extracted from the
e*mpac HR and Financials system. It provides a step-by-step approach to using some of
Excel most common features. It assumes that you

» extracted the data by copying/pasting an inquiry panel into Excel; by running a query or

by downloading a report to Excel;

= are currently viewing the document;
» have saved the document to your hard drive in Excel format.

The following terms are used in the reference guide.
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i - - = = = o, +,0 .00 | = +—'=| Sy A L
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2 00000505 0000002381 CARL SAGAM Jasagesuus 23JulH01 M
3 00000247 0000002302 HOLDEM CAUFIELD $30.14 07-Jul02 v
4 |00000337 Q000002852 HAM SOLO pakdesuus 07-Jul02 1 Worksheet
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7 00000246 Q000002817 |JAMES MORIARTY $13.87 11-Jull2 Y
g 00000302 0000002856 | 1SAAC MEWTOM $48.38 11-Jul02 v
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Problem Cells are showing #### instead of actual data.
Columns are too narrow or the columns are too wide.

Solution The column is not wide enough to display the data. Make the column wider.
Example The Gross Amount Paid column in the following worksheet is not wide enough to display the

data in the cells correctly. The Name column is too wide. Change the column widths to
make the data fit properly.

A, | B | C = E |
Paid Payment

1 Youcher Yendor Hame Amou Date
2 /00000300 0000002846 Bing, Chandler HHHHT 23-Jul-02
3 (00000079 00000027Y85 Holmesz, Sherlock $10.00 24-Jul-02
4 | 00000260 0000002817 Moriarty, James HHHHT 24-Jul-02
h | 00000246 0000002817 Moriarty, James $13.87 11-Jul-02
B |0000007S 0000002856 | Mewton, lzaac $5.00 23-Jul-02
7 00000303 0000002856 | Mewton, lzaac $48.38 11-Jul-02
8 00000298 0000002857 Pazteur, Louis $45.39 10-Aug-02
9 |00000327 0000002857 | Pastewr, Louis fadadisy 24-Jul-02
10 |00000337 0000002881 | Sagan, Carl HiHH 23-Jul-02
11 | 00000245 0000002881 | Sagan, Carl $6.93 10-Jul-02
12 |00000247 0000002881 | Sagan, Carl 33014 07-Jul-02
13 | 00000505 0000002881 | Sagan, Carl bajadiay 23-Jul-01
14 | 000002582 0000002850 | Skywalker, Luke padadnds 10-Jul-02

Instructions Step 1: Click and hold to drag the boundary on the right side of the column heading. Make
the column wider or narrower as needed.

Drag to rezize
A B _+hC
1
2
3
Results The column widths have been changed.
A | B | C | D | E |
Grozs Paid Payment
1 Youcher Yendor Mame Amount Date
¢ |00000300 0000002846 | Bing, Chandler $12337 23-Jul-02
3 | 00000079 0000002785 Holmes, Sherlock, $10.00 24-Jul-02
4| 00000260 000000237 Moniarty, James $500.00 24-Jul-02
5 | 00000246 0000002317 | Morniarty, James $13.87 11-Jul-02
B |000000Fs 0000002356 | Mewton, lsaac $5.00 23-Jul02
¢ | 00000303 0000002356 | Mewton, lsaac $48.38 11-Jul02
8 | 00000292 0000002357 | Pasteur, Louis $45.39 10-4ug-02
§ | 00000327 Q000002357 | Pasteur, Louis $EVE.50 24-lul-02
10 | 00000337 0000002331 Sagan, Canl 57301 23-Jul-02
11 | 00000245 Q000002381 | Sagan, Carl $E6.53 10-Jul-02
12 | 00000247 Q000002381 | Sagan, Carl 3014 07-Jul-02
13 | 00000505 Q000002381 | Sagan, Carl $126.31 23-Jul-01
14 |000o0zez 0000002350 | Skywalker, Luke $332.87 10-Jul-02
Hint Row heights can be adjusted in the same way.
A B C

1
3

|Drag to resize

Quick Reference: Using Excel to Format Output from Queries/Reports
Page 3 of 12



Problem
Solution

Example

Instructions

Results

Quick Reference: Using Excel to Format Output from Queries/Reports

Page 4 of 12

The spreadsheet does not have any column labels (i.e. a header row).

Add appropriate column labels.

The following worksheet does not have any column labels. Insert a row at the top of the

worksheet and enter names for columns.

A | B | C D | E |
1 | Doo0o300 0000002846 | Bing, Chandler $123.37 23-Jul-02
2 |00000079 0000002785 Holmes, Sherlock $10.00 24-Jul02
3 |00000260 0000002817 Moriarty, James $500.00 24-Jul02
4 |00000246 0000002817 Moriarty, James $13.87 11-Jul02
h | 00000075 0000002856 | Mewton, |saac $5.00 23-Jul-02
F | 00000303 0000002856 | Mewton, |saac 4838 11-Jul-02
¢ | 00000293 0000002857 | Pasteur, Louis $45.29 10-4ug-02
8 | 0000032y 0000002857 | Pasteur, Louis $E7E.50 24-Jul-02
9 | 00000337 0000002881 | Sagan, Carl $573M 23-Jul-02
10 (00000245 0000002881 Sagan, Carl $6.93 10-Jul-02
11 [00000247 0000002881 Sagan, Carl $30.14 07-Jul-02
12 00000505 0000002881 Sagan, Carl $126.31 23Jul
13 [00000282 0000002850 | Skypwalker, Luke $332.87 10-Jul-02

Step 1: Click once on the -1 | next to cell A1. This will highlight the entire row.

Step 2: Select Insert > Rows.

Step 3: Type the label of the first column (Column A) and press Tab to move to the next

column.

Step 4: Continue entering the column labels until done.

Step 5: If the row is no longer highlighted, then select (highlight) the cells containing the
column labels. Format the column labels using the font, size and color tools on the toolbar.

J M3 Sans Serif
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-&vivm

The columns contain descriptive formatted labels.

A E | C D | E |
1 _|Youcher Vendor Hame Grogs Paid Amt Pmt Date
¢ 00000300 0000002846 Bing. Chandler $123.37 23Jul-02
3 00000079 0000002785 Holmes, Sherlock $10.00 24-Jul-02
4 00000260 0000002817 | Moriarty, James $500.00 24-Jul-02
500000246 0000002817 | Moriarty, James $13.87 11-Jul-02
A | 00000078 0000002856 | Mewton, |saac $5.00 23Jul-02
¢ 00000303 0000002856 | Mewton, |saac $48.38 11-Jul-02
A 00000293 0000002857 | Pasteur, Louis $45.39 10-20g-02
4 00000327 0000002857 | Pasteur, Louis $67E.50 24-Jul-02
10 | 00000337 0000002881 | Sagan, Carl $573.01 23Jul-02
11 | 00000245 0000002881 | Sagan. Carl $6.93 10-Jul-02
12 | 00000247 0000002881 | Sagan, Carl $30.14 07-Jul-02
13 | 00000505 0000002881 | Sagan. Carl $126.21 23-Jul-m
14 | 00000232 0000002850 | Skywalker, Luke FIILET 10-Jul-02



Problem The columns are not in the correct order.
Solution Cut and paste entire columns in the correct order.
Example The following worksheet has Pmt Date in the last column. Move the Pmt Date to the left of
Voucher to make it the first column.
A E | C | D | E |
1 |Voucher Yendor Hame Gross Paid Amt Pmt D ate
¢ [00000300 0000002846 | Bing. Chandler $123.37 23Jul-0z2
3 00000073 0000002785 Holmes, Sherlock $10.00 24-Jul-02
4 | 00000260 0000002817 Moriarky, J ames $500.00 24-Jul-02
b | 00000246 0000002817 Moriarty, James $13.87 11-Jul-02
£ |00000078 0000002856 Mewtan, lsaac $5.00 23Jul-02
7 | 00000303 0000002856 Mewton, lsaac $48.38 11-Jul-02
& |00000298 0000002857 | Pasteur, Louis $45.39 10-40g-02
9 00000327 0000002857 | Pasteur, Lois $E7E.50 24-Jul-02
10 | 00000337 0000002831 Sagan, Carl $573.01 23Jul-02
11 | 00000245 0000002831 Sagan, Carl $£.93 10-Jul-02
12 | 00000247 0000002831 Sagan, Carl $30.14 07-Jul-02
13 | 00000505 0000002831 Sagan, Carl $126.31 23Jul-0
14 | 00000282 0000002850 | Skywalker, Luke $332.67 10-Jul-02
Instructions  Step 1: Select the entire column by clicking on column header of the column you want to
move. The column headers look like this:
A | B | C [ D [ E |
Step 2: Click the & on the toolbar.
Step 3: Click on the column header to the right of where you want the column inserted.
Step 4: Select Insert > Cut Cells.
Results The column you cut is pasted to the left of the column you selected.
A | B | ¢ | D | E |
1 Pmt Date Youcher Yendor Mame Gross Paid Amt
2 23-Jul-02| 00000300 0000002346 Bing, Chandler $123.37
3 24-Jul-02| 00000073 0000002725 | Holmes, Sherdock $10.00
4 24-Jul-02| 00000260 0000002817 | Moriarty, James $500.00
b 11-Jul-02| 00000245 0000002817 | Moriarty, James $13.87
B 23-Jul02| 00000078 0000002856 Mewton, |zaac $5.00
7 11-Jul-02| 00000303 0000002856 Mewton, |zaac $48.38
a8 10-4ug-02| 00000298 0000002857 Pasteur, Lois $45.39
] 24-Jul-02| 00000327 0000002857 Pasteur, Louis $676.50
10 23-Jul02| 00000337 0000002351 | Sagan, Carl $573.01
11 10-Jul-02| 00000245 oooono2e31 | Sagan, Cail $6.93
12 07-Jul-02| 00000247 0000002351 | Sagan, Carl $30.14
13 23-Jul-01 | 00000505 oooono2e31 | Sagan, Cail 1261
14 10-Jul-02| 00000282 0000002850 | Skywalker, Luke $332.87
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Problem
Solution

Example

Instructions

Results

There are columns with repetitive or unnecessary information.

Delete or hide the columns that contain the repetitive or unnecessary information.

In the worksheet below, you can see that several columns contain repetitive information. The
Unit and SetID columns hold only one value (UMLOW) and the Vendor Classification column

contains Employee. Delete these columns.

Step 1: Click on the column heading of the column you want to delete.

A B [ ¢ ] D [ E [ F ] G H

Gross

Paid Payment Yendor
1 Unit Youcher SetlD Yendor Name Amount Date Classification Withholding?
2 |UMLOWw 00000078 ULOW 0000002784 'wiLLIAM T. KIRK 5.00/2002-07-23 | Employes M
3 |UMLOW 00000079 UtLOW 0000002785 | SHERLOCK HOLMES 10.00 200207-23 Employee M
4 |UmMLOWw | 00000247 UkLO% | 0000002802 HOLDEMW CAUFIELD 30,14 2002-07-25 Employes hd
5 |UMLOW 00000245 UtLOW | 0000002317 | JAMES MORIARTY £.93/2002-07-25 Employes ks
6 |[UMLOW 00000246 UtLOW | 0000002317 | JAMES MORIARTY 13.87 200207-25  Employee ks
7 |UMLOw 00000232 UmLO%W 0000002835 JEAM-LUC PICARD 45,359 2002-07-25 Emplayes Y
8 |UMLOW | 00000300 UtLOW 0000002846 | CHANDLER EING 123.37 20020725 | Employes ks
9 |UMLOW | 00000260 UtLOW | 0000002847 | JOSEPH TRIBIANI 500.00 20020725 | Employes M
10 |UMLOW | 00000296 UmLOW | 0000002847 | JOSEPH TRIEIANI 500.00 20020725 | Employes M
11 |UMLOW | 00000302 UmLOW 0000002848  MOMICA GELLER 188.23 20020725 | Employes ks
12 |UMLOW | 00000306 UtLOW 0000002849 | FRODO BAGGIMNS 564.41 20020725 | Employes ks
13 |UMLOW 00000282 ULOW 0000002850 | LUKE SKvWwWaLKER 332,87 20020725 | Employes ks
14 |UMLDw | 00000337 UmLOW 0000002852 HAM SOLO 573.01 200207-25 Employes Ad
15 |UMLOW 00000303 UtLOW 0000002856  |1SAAC MEWTON 48,38/ 200207-25 | Employee ¥

Step 2: Select Edit > Delete to delete the column or select Format > Column > Hide.

5 vicrosot Excel-ap_alL_pihTs EpLppoveEx JRISTET
File | Edit Wiew Insert Format Tools Data Window Help Acrobat =18l i||
Paste Specil... r u ‘ B % , %% ‘ S B A -
Delete B o s A A g - B
Delste Sheet
M e Shest...
) r Classification
& Find... Chrl+F [ D [ E F | ©
Gross
gz i Paid Payment Yendor
1] 10 ¥ Vendor Name Amount _ Date Classification | Withholding?
2 |UMLOW 00000078 UMLOW | 0000002724 |WILLIAH T, KIRK. 5.00 20020723 |Emplayes H
3 |UMLOW 00000079 UMLOW 0000002785  SHERLOCK HOLMES 10.00/20020723  |Emplayes 1
4 |UMLOW 00000247  UMLOW 0000002802 HOLDEN CAUFIELD 30.14/20020725  |Emploves v
5 |UMLOW 00000245  UMLOW 0000002817  JAMES MORIARTY £.93 20020725  |Emploves v
6 |UMLOW 00000246  UMLOW 0000002817  JAMES MORIARTY 13.87/20020725  |Employes v
7 |UMLOW 00000292 UMLOW 0000002833 | JEAMLUC PICARD 45.39/20020725  |Employes v
§ |UMLOW 00000300  UMLOW 0000002846 CHAMDLER EING 123.37/200207 25 |Employes v
9 |UMLOW 00000280 UMLOW 0000002847  JOSEPH TRIBLANI 500.00 20020725 |Employes H
10 |UMLOW  DO000236  UMLOW (0000002847 | JOSEFH TRIBIANI 500.00 20020725 |Emploves [
11 |UMLOW 00000302 UMLOW 0000002845 MONICA GELLER 168.23 20020725 |Emploves v
12 |UMLOW 00000306 UMLOW 0000002843 FRODO BAGGING 5644120020725 |Emploves v
13 |UMLOW 00000282 UMLOW 0000002850 LUKE SKYWALKER 33267 20020725 |Employes v
14 |UMLOW 00000337 UMLOW  D000002852 | HAN SOLO 573.01 20020725 |Employes v
15 |UMLTW 00000303 UMLDW 0000002856 1SAACNEWTON 48.38/20020725  |Employes v Jﬂ
144 » [MMQUERY 141 0|
|owe s & | aweshepes- N N\ OCEAE &-L-A-===8@.
Ready [T I |

NOTE: You can always use the Unhide command later. You may not be able to “undelete”

the column.

The worksheet no longer displays columns with repetitive and unnecessary data.
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A | B [ | D | E | F |
Gross
Paid Payment
1 Youcher Yendor Mame Amount Date Withholding?
2 |00oooo7s 0000002784 WwILLIAM T. KIRK 5.00 2002-07-23 M
3 |00000079 0000002785 | SHERLOCK HOLMES 10,00 2002-07-23 M
4 00000247 0000002802 'HOLDEM CAUFIELD 3014 20020725 Y
5 00000245 0000002217 JAMES MORIARTY E.93 20020726 v
£ 00000246 0000002817 JAMES MORIARTY 1387 2002.07-25 Y
¢ 00000233 0000002539 JEAN-LUC PICARD 45,39 2002-07-25 Y
8 |00000300 0000002548 CHAMDLER BING 12337 2002-07-25 %
5 |00000zZE0 0000002547 | JOSEPH TRIBLANI 500,00 2002-07-25 M
10 |00000296 0000002547 | JOSEPH TRIBLAMI 500.00) 2002-07-25 M
11 |00000302 0000002843  MOMNICA GELLER 158,23 2002-07-25 Y
12 |00000306 0000002243 FRODO BAGGIMNS 5E64.41 20020725 Y
13 |00000282 0000002850 LUKE SKEYwALKER 33287 20020725 Y
14 |00000337 0000002852 HaM 50LO 57401 2002-07-25 %
15 |00000303 0000002856 | 1S&4AC NEWTON 48,38 2002-07-25 Y
16 |000D00327 0000002857 | LOIUS PASTEUR 676.50 2002-07-25 M
17 | 00000505 0000002881 | CARL SAGAM 126.31 2002-07-29 M
18 00000503 0000002881 | CARL SAGAMN 287.96 2002-07-23 M
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Solution
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Results
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Dollar amounts are not being displayed correctl

y (i.e. with $).

The columns are not formatted to display the data correctly.

In the worksheet below, the Gross Paid Amoun
cells to display the data as currency.

t column contains dollar values. Format the

Step 1: Select the range of cells that need to b
Step 2: Select Format > Cells...
Step 3: On the Number tab, make selections a

Step 4: Click OK.

Mumber | Alignment I Fant | Border I Patterns I Protectionl

A | B | C | o | E | F |

Gross
Paid Payment

1 Youcher Yendor Mame Amount Date Withholding?

2 _|00onoo7s 0000002724 WwILLIAM T. KIRK 5.00 2002-07-23 M

300000073 0000002785 SHERLOCK HOLMES 10,00 2002-07-23 M

4 00000247 0000002502 HOLDEM CaUFIELD 3014 2002-07-25 Y

5 |00000245 0000002817 JAMES MORIARTY £33 20020726 Y

£ |00000246 0000002817 JAMES MORIARTY 1387 2002.07-25 Y

¢ 00000233 0000002539 JEAN-LUC PICARD 45,39 2002-07-25 Y

8 |00000300 0000002548 CHAMDLER BING 12337 2002-07-25 %

5 |00000z2E0 0000002547 | JOSEPH TRIBLAMI 500,00 2002-07-25 M

10 |00000296 0000002547 | JOSEPH TRIBLAMI 500,00 2002-07-25 M

11 |00000302 0000002548 MOMNICA GELLER 158,23 2002-07-25 %

12 |00000306 0000002549 FRODO BAGGINS 564.41 2002-07-25 %

13 |Doooozs2 0000002850 | LUKE SKywaALKER 33287 2002-07-25 %

e formatted as currency.

s shown below.

Category: ample
Gross Paid Armount ‘

1. In the Category area, select Currency.

Cecimal places: |2 E‘ |
Syrbal:
|

Megative numbers;

$1,234. 10
t$1,234.10)
i41,234.10) =

2. In the Decimal places field, type 2 or use the
up/down arrows.

3. Select the $ from the Symbol drop-down list.

the Negative numbers field.

4. Select the format you'd like for negative numbers in

Currency formats are used for general monetary values. Lse Accounting 5. Click OK.
farmats ta align decimal points in & column.
oK I Cancel |
The worksheet displays the data as currency.
A B [ C [ Do ] E | F |
Gross
Paid Payment
1 Youcher Yendor Mame Amount Date ‘Withholding?
2 | 00000073 Q000002784 |wiILLIAM T. KIRE $5.00) 2002-07-23 M
3 _|000o007a 0000002785 SHERLOCK HOLMES $10.00 2002-07-23 M
4 |00000247 0000002802 HOLDEMW CAUFIELD 3014 20020725 Y
5 |00000245 0000002817 JAMES MORIARTY $6.93 20020725 W
B |00000245 0000002817 JAMES MORIARTY $13.87 20020725 Y
7 100000293 0000002839 JEAM-LUC PICARD $45.39 2002-07-25 Y
8 |00000300 0000002846 CHAMDLER BING $123.37/ 20020725 Y
3 00000280 0000002847 JOSEPH TRIBLAMI $500.00) 20020725 M
10 | 00000238 0000002847 JOSEPH TRIBLAMI $000.00) 20020725 M
11 | 00000302 aooooozeds  |MOMICA GELLER $158.23| 2002-07-25 Ay
12 | 00000308 0000002849 FRODO BAGGIMS $0E4.41| 20020725
13 |0o0oo2g2 Q000002850 |LUKE Sk walkER $332.87| 2002-07-25 Ny




Problem

Solution

Example

Instructions

Results

The output is not sorted in the correct way.

Use Excel’s sort feature to re-organize the data. In the example below, the output is sorted
by the Vendor number. You might find that sorting by payment date is more useful to you.

The following data needs to be sorted by Name and Payment Date.

A B | C | o | E |
Grozs Paid Payment
1 Youcher Yendor Hame Amount D ate

_ 2 |0000007g 0000002856 | Mewton, |saac $5.00 23Jul-0z2
_ 3 |0000o00@g 0000002785 | Halmes, Sherack $10.00 24-Jul-02
_ 4 | 00000245 0000002881 | Sagan, Carl $6.93 10-Jul-02
_ & |00000248 0000002817 Mariarty, James $13.87 11-Jul-02
_ B |00000247 0000002881 | Sagan, Carl $3014 07-Jul-02
_ 7 |0o0o0zen 0000002817 Mariarty, James $500.00 24-Jul-02
_ 8 |0o000zez 0000002850 Skywalker, Luke 33287 10-Jul-02
_ 9 |0000029 0000002857 | Pasteuwr, Louis $45.39 10-4ug-02
10 | 00000300 0000002346 Bing. Chandler $123.37 23Jul-02
11 | 00000303 0000002856 | Mewton, |saac $48.38 11-Jul-02
12 | 00000327 0000002857 | Pasteuwr, Louis $676.50 24-Jul-02
13 | 00000337 0000002881 | Sagan, Carl $573.01 23Jul-02
14 | 00000505 0000002881 | Sagan, Carl $126.3 23Jul-o

Step 1: Determine which column will be used as your primary sorting criteria. You may also
want a secondary sort criteria. For example, you may want to sort by Payment Date and then

by Gross Paid Amount.

Step 2: Select Data > Sort...

Step 3: Select the sort criteria as shown below. The drop-down lists will contain the Column

Labels (headers).

Sork by

IName .I & ascending

" Descending

2]

Then by
 ascending

*ayment Dake

¢ Descending

& ascending

” Descending
Iy list has

" Mo header row

[ ]

% Header row

optians. .. | Cancel

Step 4: Click OK.

1. Select the Header row radio button at the bottom.

2. From the Sort by drop-down list, select the column
you want as the primary sort criteria.

3. From the Then by drop-down list, select the column
you want as the secondary sort.

4. Click OK.

The data is sorted according to the primary and secondary criteria you entered.

A B | C | D | E |
Grogs Paid Payment

1 Youcher Yendor Mame Amount D ate
2 00000300 0000002846 | Bing, Chandler $123.37 23-Jul-02
3 [00000079 0000002785 Holmes, Sherlock $10.00 24-Jul-02
4 | 00000260 0000002817 Moriarty, James $500.00 24-Jul-02
5 [00000246 0000002817 Moriarty, James $13.87 11-Jul-02
F 00000078 0000002856 | Mewtan, |saac $5.00 23-Jul-02
¢ 00000303 0000002856 | Mewton, |zaac $48.38 11-Jul-02
A 00000293 0000002857 Pasteur, Lauis $45.39 10-Aug-02
9 |00000327 0000002857 Pasteur, Louis $67E.50 24-Jul-02
10 | 00000337 0000002881 | Sagan, Carl $573.01 23-Jul-02
11 | 00000245 0000002881 | Sagan, Carl $6.93 10-Jul-02
12 | 00000247 0000002881 | Sagan, Carl $30.14 07-Jul-02
13 | 00000505 0000002881 | Sagan, Carl $126.31 23-Jul-n
14 | 00000282 0000002850 | Skywalker, Luke $332.87 10-Jul-02
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Problem

Solution

Example

Instructions

The spreadsheet contains too many rows of data. | just want to view the rows that are
relevant to me.

Use Excel’s filter capability to view a subset of the data. Excel will display only the rows of
data that meet the criteria you specify.

The list in the example below is filtered to show only the rows for the salesperson Davolio.

A | B | © | D —Funiteredig
1 |Salesperson Region Type Sales
2
3
4 A B C D
5 1 |Salesperson |lRegiun |LT}F|]E tﬁales |L
b 3 |Davolio Wiest Dairy 3338
I 7 |Davolio South Meat 450
8 & |Davolio South Mest 7ET3
4 10 |Davolio North Produce 1,500
100 5Y |Davalio South Produce B S
L+ 22 |Davolio East Produce 2741
Fitered list _-HPF Produce T,D*ﬁr

Step 1: Determine which column(s) will be used as your primary filtering criteria. Click on a
cell in the list you want to filter.

Step 2: Select Data > Filter > AutoFilter. Arrows appear to the right of the column labels.
Step 3: Click on the arrow to display a list of all unique values found in that list.

Step 4: Select the value to display all rows containing that value. Notice that you can also
choose (Blanks) or (NonBlanks).

Fd Microsoft Excel - STUDENT_PW_Test I [m] 4]
J File Edit Yiew Insert Format Tools Data ‘Window Help Acrobat ;lili”
DEFELERY I BBF o - |@ = &2 B0 -0,
E1 ~| =| Dept
A B € o C =
| 1 |[Name =|ID _=| Empl Red »|HRDeptlD | | 1. Click the arrow to display the list of values.
| 2 |Acheampong,Betty 10043060 0 L&20339 A |CWSP Ing
| 3 |Acheson Brian E 10014216 2 e Chemical § 2. Select a value. Only rows containing that
| 4 |Acheson,Brian E 10014216 3 L&50700 Research | value will be visible.
| & |Acheson,Brian E 100142116 4 Research
| B |Achin Jeremy D 10037444 1 L700100 Library
| 7 |Adams,Gregary 10045254 ] L700101 Fesidence Halls 99
| 8 |Adams, Jeremy 10023261 ] L720315 Research Foundation
| 9 |Adams Jeremy 10023251 1 L720327 Research Foundation
| 10 |Adams Kate 10042290 T e Research Foundation
| 11 |Adams Mally 10005550 1 L720405 Fesidence Halls 99
| 12 |Adapala Lakshmi 100124608 0 L7za410 Research Foundation
| 13 |Adapala Lakshmi 10012508 4 e Research Foundation
| 14 |Adesina,Oladejo 10040002 0 760510 Carpus YWrk Program Engineering
| 15 | Agalliu,llir 10020082 5 L20a000 Research Foundation
| 16 |Agalliu,lir 10020082 B Eﬁ'gg';f;nks) Z{Research Foundation
| 17 |Agbottah, Emmanuel 10050579 0 C3 10040 Carmpus Work Program Provost -
4[4[ M\ Sheet1 / shestz [ sheet3 | 4] ﬂj_‘
Ready [ sl [ [ [ 4

Step 4: To view the entire spreadsheet again, select Data > Filter > AutoFilter.

Quick Reference: Using Excel to Format Output from Queries/Reports
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Results

Notes

The data is filtered according to the criteria you entered.

Fd Microsoft Excel - STUDENT_PW_Test 1Ol =]
J File Edit Yiew Insert Format Tools Data indow Help Acrobat ;Iilﬂ|
DRSS SGRY $B2BRT ©-c &= £ 285 0w -2
D1 | =| HRDeptID
A B & D E =

1 |Hame ~|ID x| Empl Red > [HRDeptiD ~IDept ==
109 |Bartlett Angus 10000561 0 L E90710 Escort Services
110 |Bartos Eva 10020775 1 LEa0710 Ezcort Services
118 |Belair Jeffrey D 10015889 2 LE90710 Escort :
485 |Fiske,Sean C 10026193 0 LE90710 rt| Only the rows containing the value you
486 |Fiske,Sean C 10026199 1 LE20710  |Escort| specified in this column are visible.
510 | Gagnon,Sabre A 10000153 0 LB90710 Escornt semvTe
513 |Gagnon,Sarah J 10000099 ] LE90710 Escort Services
897 | Gretsky Jason M 10012296 2 LB90710 Escort Services
737 |Jarvis Michael 10046077 1 LE90710 Escort Services
1001 (Matos Jason 10025267 2 LE30710 Escort Semices
1063 |Mohyuddin, Saba 100301145 ] LE90710 Escort Services
1270|Pochette Nodeige 10028695 0 LB90710 Escort Services
1288 |ProiaJohn 10012330 0 LE90710 Escort Serices
1584 | Then, Dayanett M 10023804 0 LB90710 Escort Services
1591 | Thurston Eric 10044763 1 LE90710 Escort Serices
1756 | WWyman Rosalind 10016714 il LF30710 i [=|
[4[4[» [m["Sheet1 { shestz £ Sheets / 14
17 of 1787 records found | [ [ [l | I (I

You can make selections from more than one column. Each time you make a filtering
selection from another column, you are further limiting your list (using a logical AND). In the
example below, you are viewing only the rows of data that have an HRDeptID of L690710
and an Hrly Rate of 10.00. These are all the student employees working in the Escort
Services area and making $10/hr.

Ed Microsoft Excel - STUDENT_PW_Test

|BF] Bile Edit wiew Insert

Format Tools Data Window Help Acrobat

=10l =
==l x|

DEEe 8k

VI $ BB S 0o

@z A& 8l §l|ﬂ1un% -

23

D1 | =| HRDeptID

A B c | D | E H =

1_|Name ~|ID | Empl Red x [HRDeptD ~ |Dept x|Hrly Rate ~ |~
109 |Bartlett Angus 10000561 ] LE30710 Escort Services 10.00
118 |Belair Jeffrey D 100158589 2 LB90710 Escort Services 10.00
485 |Fiske Sean C 10026199 0 LB30710 Escort Services 10.00
486 |Fiske Sean C 10026199 1 LB30710 Escornt Services 10.00
510 |Gagnon,Sabre A 10000183 ] LEI07 10 Eszcort Services 10.00
207 |Gretsky Jason M 100122596 2 LE30710 Escort Services 10.00
737 |Jaris Michael 10046077 1 LE30710 Escort Services 10.00
1270{Pochette Nodeige 10028695 0 LB90710 Escort Services 10.00
1288 |Proia,Jokn 10012330 ] LEI07 10 Escort Serices 10.00
1591 |Thurstan Eric 10044753 1 LEI07 10 Escort Services 10.00
1756 [%Yyman Rosalind 10016714 ] LE30710 Escort Services 10.00

1772|Zande Kimberly A 10024159 0 LB90710 Escort Services 10.00 75

1414 » (¥ Sheet1  Sheetz £ Sheets 7 4] I

Filter Mode I [ e e e e
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Problem

Solution

There are no totals or subtotals in the spreadsheet.

The query/report was not designed to provide the information. However, Excel provides
several options for calculating totals and sub-totals. Microsoft Excel can automatically
summarize data by calculating subtotal and grand total values in a list. To use automatic
subtotals, your list must contain labeled columns and the list must be sorted on the columns
for which you want subtotals, as shown below.

A | B | c ] D
| 1 |Salesperson Type Units Sales |-C|:|Iumn labels
| & |Buchanan Cairy | 9206 4,562
| 3 |Buchanan Dairy | 2021 9,136
|4 | Buchanan Lairy | 39581 2428 <«4— | Inthis example, we have sorted (grouped)
| 5 |Buchanan Meat | 3213 3,106 the output by Salesperson in order to
| B |Buchanan Mest | 3389 5012 calculate the Sales total for each one.
L Davolio Dwairy 1695 3338
| 8 |Dawvalio hiest 230 450
9 | Davolio hest 5411 TEVS
[ List zarted by the Salesperson

and Type columns

You can select which type of function or calculation you want Excel to perform on each
group. The most common function is the Sum function, where you calculate a total (sum) for
each group.

1]2[3 A | B | c | D
5= %g:;:::;sun J;;::{e :HQIESE TIS?; <4—— | Inthis example, you can see a Sales total
™3 |Buchanan Dairy 2'021 9'1 = for each Salesperson and a Grand Total at
= ! ! the bottom.
| 4 |Buchanan Dairy |~ 39681 2428
B |Buchanan heat 3219 3106
- | B |Buchanan Mest = 3339 agoiz ||Subtotsls
El L Buchanan Total 21816 27 244
[ - iDavolio Drairy 16895 3,338
| 5 |Davolio heat 230 450
- ﬂDavolio heat 5,411 7 EYS
[=] |11 ]|pavolio Total 7336 11,461
[=] 12 |Grand Total 29152 33,705 |F Grand total
|Outline symbols

Step 1: Sort the data on the columns by which you want the subtotals grouped.
Select Data > Sort... and select your primary and secondary sort criteria.

A B | C | D | E |
Gross Paid  Papment

1 Youcher Yendor Hame Amount D ate
7 00000505 OOODDO0ZB81 | Gagan, Carl T126.31 FENTEY
3 [00000247  0OODDO2831 | Sagan, Carl $30.14 O7-Jul02
4 |D0000Z45  DOODDO2BB1 | Sagan, Carl $6.93 10.Jul-02 )
B 00000337 OODODOZ8E1  Sagan, Carl 457301 23.ul02 € In this example, the data
B 00000200 00DOOOZEG46  Bing, Chandier $12237 2302 was sorted by Name and
7 100000303 O0DOO02856  Mewton, lsasc 448,39 T1-Jul02 by Payment Date.
§ |0000D072 DOODDOZESE | Mewton, lsasc $5.00 23Juk02 o
9 |0D0D0245  DDOOODZET7 | Mariarty, James $13.87 11-Jul 02 This will allow usto
10 00000260 | 00000027 | Moriarty, James $500.00 24-Jul02 calculate the Gross Paid
11 00000327 | DO0ODO2857  Pasteur, Lois $576.50 24-Jul02 Amount for each person
12 00000238 | 0000002857 | Pasteur, Louis $45.39 1002 and a Grand Total.
13 |0000D282 | DOOOOOZES0 | Skywalker, Luke $332 87 10.Jul-02
14 (00000079 | OOOODO2785 | Holmes, Sherack $10.00 24-Jul02

Step 2: Select Data > Subtotals...

Quick Reference: Using Excel to Format Output from Queries/Reports
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Results

Step 3: Make selections as shown below.

Ak each change in:

P - <«

s Function;

2 x|

-
ISum J ¢
Add subkotal bo;
[ Mame -
=
[~ Payment Date ;I 44—

¥ Replace current subtotals
[ Page break between groups
W Summary below data

[ |

Rermoyve Al | Cancel

Select how you would like your data grouped. This should be
the same column bv which vou sorted vour data in Sten 1.

Select the function you'd like to use. The Sum function is the
most common but you may also choose Count, Average, Max,
Min, etc.

Select the checkboxes for the columns that contain the data
for which you want subtotals.

What did this do?

For each new name in the list, Excel will calculate the sum of
the Gross Paid Amount and a grand total.

Step 4: Click OK.

The results are shown below.

EE A ] E | C [ O ] E |
Grozs Pard Payment
1 Youcher Yendor Mame Amount Date
[ 2 | 00000505 Q000002881 Sagan, Cail $126.31 23-Jul-
3 | 00000247 0000002881 Sagan, Cail $30.14 07-Jul-02
4 | 00000245 0000002881 Sagan, Cail $6.53 10-Jul-02
- | B 00000337 Q000002881 Sagan, Cal $a73.01 23-Jul02
= [B Sagan. Carl Total $736.39
- 7 |000o0300 0000002846 Bing, Chandler $123.37 23Jul-02
= a Bing. Chandler Total $123.37
- | 9 00000303 0000002856 Mewton, |saac $48.38 11-Jul02
- | 10 |0ooDoo07e Q000002856 Mewton, [zaac $5.00 23-Jul-02
= 11 Mewton, lsaac Total $53.38
- | 12 | 00000246 0000002817 Moriarty, James $13.87 11-Jul02
- | 13 |000oozen 0000002817 Moriarty, James $500.00 24-Jul-02
= 14 Moriarty, James Total $513.87
|- « | 15 | 00000327 Q000002857 Pastewr, Louiz $67E.50 2-Jul-02
- | 16 | 00000298 0000002857 | Pastewr. Louis $45.29 10-Aug-02
= 17 Pasteur. Louis Total $721.84
[ - | 158 |000ooz2s2 0000002850 | Skywalker, Luke $332.87 10-Jul-02
= 19 Skywalker, Luke Total $332 87
[ - | 20 |00000079 0000002785 Halmes, Sherack. $10.00 24-Jul-02
I=| 21 Holmes, Sherlock Total $10.00
= e Grand Total $2.491.77

Quick Reference: Using Excel to Format Output from Queries/Reports
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